summaryrefslogtreecommitdiff
path: root/CanDevToolSettings.mdwn
blob: 314893bc1907208ad14a21d0086d488541bedb2d (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
# <a name="CAN Node Development Tools"></a> CAN Node Development Tools

**_DANGER DANGER! THESE INSTRUCTIONS ARE OUTDATED AS OF 02/03/2004!!! CONTACT ANDREW IF YOU NEED HELP SETTING STUFF UP!_**

Here are the installation instructions to setup our tools:

## <a name="Installing MPLAB IDE:"></a> Installing MPLAB IDE:

1. Remove any old MPLAB installs, especially older 5.xx versions.
2. Install MPLAB 6.10. Choose ALL of the defaults EXCEPT put the linker files in the /lkr directory (if it still asks).

## <a name="Installing PICC-18:"></a> Installing PICC-18:

1. Double click the PICC-18 installer. Choose ALL default options. Completely restart - don't just choose "shift restart". You need to reload the config.sys/autoexec.bat files.
2. Register your copy by running Start -&gt; Programs -&gt; HI-TECH Software -&gt; Compiler Activation. Enter in the activation information (ask Andrew if you don't have it) and you should get a DOS box. Click off the DOS box, and you should get a registration succesfull message.
3. Run the patch program and answer yes to all questions (if you have the newest versions of each).

## <a name="Setting up MPLAB IDE to work wit"></a> Setting up MPLAB IDE to work with PICC-18:

1. Run MPLAB.
2. Choose the "Project" menu and "Set Language Tool Locations...".
3. Set ALL THREE tools in the "HI-TECH PICC-18 Toolsuite" (NOT the "PICC Toolsuite, that's for an older core) to "C:\\HTSOFT\\PIC18\\bin\\picc18.exe". You might want to use the browse button just to make sure you get the path right.
4. Hit Ok.
5. You should now be able to load the project for your application (.pjt file) and compile it.
6. IF YOU USE THE ICD2: Choose the "Project" menu and select "build options"
7. Under the HI-TECH18C Compiler tab select "Output &amp; Debug" from the Categories drop down menu.
8. Put a check in the box "Compile for MPLAB ICD"
9. Under the HI-TECH18 Linker tab place a check in the "Link for ICD" box.

----

## Can King Installation and Settings

Install CAN King with all the default options. You'll need about 25MB, and a working parallel port. Note that if CAN King says "No Parallel Port Present" then you should check your parallel port's address.

When you first open up Can King:

- When you open Can King, hit "OK, I know what I'm doing".
- Choose "Template".
- Choose "MCP2510 Evaluation Board".

Setup parallel port, board, and environment:

- Menu "Options" -&gt; "Global":
  - Set "Autosave layout" on.
  - Choose "Hexadecimal" as "Default numeric base".
- Menu "Options" -&gt; "MCP2510":
  - Clock frequency: 16000kHz
  - Make sure your parallel port address is correct.
- Inside "MCP2510 Can Controller" window:
  - Click "Go off bus".
  - Switch to "Bus Parameters" tab.
  - Set "Bus Speed" = 1000Kbps.
  - Set "Sampling Point" = 75%.
  - Set "SJW" = 1.
  - ("Driver mode" should be "Normal".)
- Menu "Messages" -&gt; "Universal" -&gt; "Universal"

When you quit:

- "File" -&gt; "Exit"
- "Save changes?" Say yes.
- Remember where you saved the project.

On next start:

- When you open Can King, hit "OK, I know what I'm doing".
- Choose "Open an Existing Project".
- Open whatever you saved the project as.